Magento Paypal IPN Patch

Magento Paypal IPN Patch

15:27 14 June in E-commerce Solutions, eCommerce, Magento, News, Security

Paypal will end support for HTTP callbacks to their Instant Payment Notification (IPN) service on June 30th, 2017. After that date merchants and partners using IPN will be required to use HTTPS for postback messages to Paypal.

If your Magento store uses Paypal with IPN enabled we highly recommend upgrading to Magento 1.9.3.3 or applying the recently released SUPEE-8167 patch. Magento 2.0 stores are urged to upgrade to 2.0.15 as soon as it has been released. This only applies to merchants that depend on the IPN service from Paypal. If you don’t use Paypal, or if the Instant Payment Notification service is disabled in your Magento store there should be no problem after June 30th. If you aren’t sure ask your development team or system administrator. All releases of Magento 2.1 are compliant with this new requirement, so no action is needed in this case.

For more details see the following resources provided by Paypal and Magento:

As always, if your magento store encounters an issue our dedicated technical support staff are ready to help.